Announcement

Collapse
No announcement yet.

Connection status reading wrong

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Connection status reading wrong

    Got a weird little bug here. I was in a thread (the Myrmidon, trying to come up with something to reply with), when I realised that my info-box's connection status flag was reading me as offline.

    I immediately went to the top of the page to check if I'd been logged out by a system error. Nope; I'm definitely logged in.

    I tried refreshing the page. No effect; my connection status flag still said offline.

    I'm baffled.

    It's nothing major, just kinda confusing.

    What do you think, Daryn?

    Edit: And now it's reading me as online after posting this.

    Maybe the activity said something to the system? I dunno.
    Arratra's Signature
    Fanfiction


    Deviantart


    Insatiable Curiosity

    Major Leon Stormstrider

    Varatyr Scorchtalon
  • #2

    It seems like when you first visit the forums, the online status doesn't get immediately updated. It takes a few minutes. Doing something on the forums like replying or posting a new thread will set the online flag immediately.

    This seems like a vBulletin behaviour. I've noticed it for a good while. Sadly, I don't think there's much I can do to improve it.
    Daryn's Signature



    “Just when you think humanity has found the limits of stupid, they go and ratchet up the standard by another notch.” - Bob

    Comment

    • #3

      Strange. I'd been on for over an hour by that point.

      Might just be that I'd only loaded the relevant tabs a few minutes before, though.

      Also, yeah; if it's on V-bulletin's end, there's not a whole lot you can do about it. I understand.
      Arratra's Signature
      Fanfiction


      Deviantart


      Insatiable Curiosity

      Major Leon Stormstrider

      Varatyr Scorchtalon

      Comment

      • #4

        The way I've observed it working, is it times you off the site after about ten minutes of inactivity. So say for instance you came on and opened the Myrmidon thread, but then went off and started typing your reply in a word-editor. Alright. Good so far.

        But then, when you'd finished, you come back and try to copy and paste what you wrote. The site won't let you. That's because you hadn't attempted to navigate within the forums for a while. The forums times you out.

        That's just the way it does. Slice has complained of this problem, too. As I remember, this is what we told him. He was doing pretty much exactly what I just described.

        It's not really a big deal, though. In order to reset your time-out, just click a 'Home' link anywhere on the forums. Refreshing won't do it. It just lands you right back where you were, including with a timed-out counter. You literally have to navigate, by physically clicking a link, in order to reset your timeout.

        Also, vBulletin seems to be pretty smart when detecting inactivity. Whenever I write my posts, I do them right in the forums' editor. Like in the one right beneath the threads. I'll spend an hour or more writing in them sometimes. As soon as I hit post, the forums posts it right away, no time-out errors or anything. So working in the editor keeps you timed in, so to speak.
        Rick Canaan's Signature
        A balanced diet is an ice cream cone in each hand - Rick Canaan

        Comment

        • #5

          Ah, OK. That makes sense.
          Arratra's Signature
          Fanfiction


          Deviantart


          Insatiable Curiosity

          Major Leon Stormstrider

          Varatyr Scorchtalon

          Comment

          Working...
          X